原题地址:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1004

题目:

 
Anagrams by Stack


Time Limit: 2 Seconds      Memory Limit: 65536 KB


How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]

and the sequences should be printed in “dictionary order”. Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

Process

A stack is a data storage and retrieval structure permitting two operations:

Push – to insert an item and 

Pop – to retrieve the most recently pushed itemWe will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it\’s too short), neither is
i i o o o i (there\’s an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o
i i i i o o o o i o
i i o i o i o i o o
i i o i o i o o i o
]
[
i o i i i o o i i o o o
i o i i i o o o i o i o
i o i o i o i i i o o o
i o i o i o i o i o i o
]
[
]
[
i i o i o i o o
]

分析:

本题貌似也是比较水的题目,而且题数据规模比较小,直接搜索/穷举就能过了。不过这里有个小小的trick:

中间注意判断类似 i o o i ... 之类的不可能的情况来剪枝...否则会一直TLE....
PS:注意输出顺序和格式...

代码:

#include<iostream>
#include<string>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;

string ch,str;
stack<char>s;
vector<char>p;
int l;

void prints()
{
 int i;
 for(i=0;i<p.size();i++)
  cout<<p[i]<<” “;
 cout<<endl;
}

void dfs(int i,int j)
{
 if(i==l&&j==l)prints();
 if(i<=l-1)
 {
  s.push(ch[i]);
  p.push_back(\’i\’);
  dfs(i+1,j);
  s.pop();
  p.pop_back();
 }
 if(j<=i-1&&j<=l-1&&s.top()==str[j])
 {
  char c=s.top();
  s.pop();
  p.push_back(\’o\’);
  dfs(i,j+1);
  s.push(c);
  p.pop_back();
 }
}

int main()
{
 while(cin>>ch>>str)
 {
  l=ch.length();
  string t1=ch,t2=str;
        sort(t1.begin(),t1.end());
  sort(t2.begin(),t2.end());
  cout<<“[“<<endl;
  if(t1==t2)dfs(0,0);
  cout<<“]”<<endl;
 }
 return 0;
}

评论被关闭。